$re = '/{{(.*?)}}/m';
$str = 'Всем привет!
Подскажите пожалуйста, как можно реализовать проверку всех файлов на наличие {{}} и если есть такой синтаксис, то вставить в это место текст из например {{blog/flowers.txt}}?
Т.е. если в файле есть {{}}, то он подставит в это место текст из указанного в нём файла.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);