const regex = /{{(.*?)}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{(.*?)}}', 'gm')
const str = `Всем привет!
Подскажите пожалуйста, как можно реализовать проверку всех файлов на наличие {{}} и если есть такой синтаксис, то вставить в это место текст из например {{blog/flowers.txt}}?
Т.е. если в файле есть {{}}, то он подставит в это место текст из указанного в нём файла.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}