#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b"
Local $sString = "invalidos:" & @CRLF & _
"" & @CRLF & _
"192.268.0.1" & @CRLF & _
"1.333.1.1" & @CRLF & _
"192.168.0.256" & @CRLF & _
"256.256.256.256" & @CRLF & _
"" & @CRLF & _
"validos:" & @CRLF & _
"192.168.0.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"10.0.0.255" & @CRLF & _
"10.11.12.0" & @CRLF & _
"255.255.255.255" & @CRLF & _
"0.0.0.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")