const regex = new RegExp('\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b', 'gm')
const str = `invalidos:
192.268.0.1
1.333.1.1
192.168.0.256
256.256.256.256
validos:
192.168.0.1
127.0.0.1
10.0.0.255
10.11.12.0
255.255.255.255
0.0.0.0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}