using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b";
string input = @"invalidos:
192.268.0.1
1.333.1.1
192.168.0.256
256.256.256.256
validos:
192.168.0.1
127.0.0.1
10.0.0.255
10.11.12.0
255.255.255.255
0.0.0.0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}