import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?<protocol>https?|ssh|git|ftps?):\\/\\/)?((?<user>[^\\/@]+)@)?(?<host>[^\\/:]+)[\\/:](?<port>[^\\/:]+)\\/(?<path>.+\\/)?(?<repo>.+?)(?<suffix>\\.git[\\/]?)?$";
final String string = "ssh://git@gitlab.sickcn.net:10022/Platforms/euler/components/appengine/flow_engine.git/\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}