re = /^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<host>[^\/:]+)[\/:](?<port>[^\/:]+)\/(?<path>.+\/)?(?<repo>.+?)(?<suffix>\.git[\/]?)?$/
str = 'ssh://git@gitlab.sickcn.net:10022/Platforms/euler/components/appengine/flow_engine.git/
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end