const regex = /^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<host>[^\/:]+)[\/:](?<port>[^\/:]+)\/(?<path>.+\/)?(?<repo>.+?)(?<suffix>\.git[\/]?)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?<protocol>https?|ssh|git|ftps?):\\\/\\\/)?((?<user>[^\\\/@]+)@)?(?<host>[^\\\/:]+)[\\\/:](?<port>[^\\\/:]+)\\\/(?<path>.+\\\/)?(?<repo>.+?)(?<suffix>\\.git[\\\/]?)?$', '')
const str = `ssh://git@gitlab.sickcn.net:10022/Platforms/euler/components/appengine/flow_engine.git/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}