package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{9}|\d{3}[ -]*\d{2}[ -]*\d{4}|[ -]*(?:[0-9][ -]*){9}`)
var str = `225268541
235-55-8459
26 55 6559
261 25-4658
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}