const regex = /[0-9]{9}|\d{3}[ -]*\d{2}[ -]*\d{4}|[ -]*(?:[0-9][ -]*){9}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{9}|\\d{3}[ -]*\\d{2}[ -]*\\d{4}|[ -]*(?:[0-9][ -]*){9}', 'gm')
const str = `225268541
235-55-8459
26 55 6559
261 25-4658
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}