re = /[0-9]{9}|\d{3}[ -]*\d{2}[ -]*\d{4}|[ -]*(?:[0-9][ -]*){9}/m
str = '225268541
235-55-8459
26 55 6559
261 25-4658
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end