use strict;
my $str = '225268541
235-55-8459
26 55 6559
261 25-4658
';
my $regex = qr/[0-9]{9}|\d{3}[ -]*\d{2}[ -]*\d{4}|[ -]*(?:[0-9][ -]*){9}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}