using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^T:\ ([0-9]+[\.]{0,1}[0-9]{0,1}?)\ H:\ ([0-9]){2}\ BAT:\ [a-z]{1,3}\Z";
string input = @"T: 20.3 H: 44 BAT: ok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}