import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^T:\\ ([0-9]+[\\.]{0,1}[0-9]{0,1}?)\\ H:\\ ([0-9]){2}\\ BAT:\\ [a-z]{1,3}\\Z";
final String string = "T: 20.3 H: 44 BAT: ok";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}