const regex = /^T:\ ([0-9]+[\.]{0,1}[0-9]{0,1}?)\ H:\ ([0-9]){2}\ BAT:\ [a-z]{1,3}\Z/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^T:\\ ([0-9]+[\\.]{0,1}[0-9]{0,1}?)\\ H:\\ ([0-9]){2}\\ BAT:\\ [a-z]{1,3}\\Z', 'g')
const str = `T: 20.3 H: 44 BAT: ok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}