re = /^T:\ ([0-9]+[\.]{0,1}[0-9]{0,1}?)\ H:\ ([0-9]){2}\ BAT:\ [a-z]{1,3}\Z/
str = 'T: 20.3 H: 44 BAT: ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end