import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:^|\\b)(?<=<!--\\n)(?P<gostamp>\\d\\d\\d{1,2}[ap]m)\\n(?P=gostamp)(?=\\n-->\\n)(?:\\b|$)";
final String string = "A better option would be to just use strings.Split:\n\n"
+ "~~~\n"
+ "package main\n\n"
+ "import (\n"
+ " \"fmt\"\n"
+ " \"strings\"\n"
+ ")\n\n"
+ "func main() {\n"
+ " s := \"@636e0e0eac0bd25cd5df92a3$636e0e49ac0bd25cd5df92a5.result.result[0].code.xTrim()\"\n"
+ " a := strings.Split(s, \".\")\n"
+ " fmt.Println(a)\n"
+ "}\n"
+ "~~~\n\n"
+ "https://godocs.io/strings#Split\n\n"
+ "<!--\n"
+ "836pm\n"
+ "836pm\n"
+ "-->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}