const regex = /(?s)(?:^|\b)(?<=<!--\n)(?P<gostamp>\d\d\d{1,2}[ap]m)\n(?P=gostamp)(?=\n-->\n)(?:\b|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:^|\\b)(?<=<!--\\n)(?P<gostamp>\\d\\d\\d{1,2}[ap]m)\\n(?P=gostamp)(?=\\n-->\\n)(?:\\b|$)', 'gm')
const str = `A better option would be to just use strings.Split:
~~~
package main
import (
"fmt"
"strings"
)
func main() {
s := "@636e0e0eac0bd25cd5df92a3\$636e0e49ac0bd25cd5df92a5.result.result[0].code.xTrim()"
a := strings.Split(s, ".")
fmt.Println(a)
}
~~~
https://godocs.io/strings#Split
<!--
836pm
836pm
-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}