import re
regex = re.compile(r"(?s)(?:^|\b)(?<=<!--\n)(?P<gostamp>\d\d\d{1,2}[ap]m)\n(?P=gostamp)(?=\n-->\n)(?:\b|$)", flags=re.MULTILINE)
test_str = ("A better option would be to just use strings.Split:\n\n"
"~~~\n"
"package main\n\n"
"import (\n"
" \"fmt\"\n"
" \"strings\"\n"
")\n\n"
"func main() {\n"
" s := \"@636e0e0eac0bd25cd5df92a3$636e0e49ac0bd25cd5df92a5.result.result[0].code.xTrim()\"\n"
" a := strings.Split(s, \".\")\n"
" fmt.Println(a)\n"
"}\n"
"~~~\n\n"
"https://godocs.io/strings#Split\n\n"
"<!--\n"
"836pm\n"
"836pm\n"
"-->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")