$re = '/(?s)(?:^|\b)(?<=<!--\n)(?P<gostamp>\d\d\d{1,2}[ap]m)\n(?P=gostamp)(?=\n-->\n)(?:\b|$)/m';
$str = 'A better option would be to just use strings.Split:
~~~
package main
import (
"fmt"
"strings"
)
func main() {
s := "@636e0e0eac0bd25cd5df92a3$636e0e49ac0bd25cd5df92a5.result.result[0].code.xTrim()"
a := strings.Split(s, ".")
fmt.Println(a)
}
~~~
https://godocs.io/strings#Split
<!--
836pm
836pm
-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);