# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\b|_)you(?=\b|_)/we/gm;t' <<< "_you_don't_ think_you_don't_* you_don't__ you_don't_know_your_youth"