const regex = /(?<=\b|_)you(?=\b|_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b|_)you(?=\\b|_)', 'gm')
const str = `_you_don't_ think_you_don't_* you_don't__ you_don't_know_your_youth`;
const subst = `we`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);