import Foundation
let pattern = #"(?<=\b|_)you(?=\b|_)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"_you_don't_ think_you_don't_* you_don't__ you_don't_know_your_youth"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"we"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)