$re = '/(?<=\b|_)you(?=\b|_)/m';
$str = '_you_don\'t_ think_you_don\'t_* you_don\'t__ you_don\'t_know_your_youth';
$subst = "we";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;