#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "X-FileName:.*[\r\n]+(.+)"
Local $sString = "X-FileName: pallen (Non-Privileged).pst" & @CRLF & _
"" & @CRLF & _
"Here is our forecast" & @CRLF & _
"" & @CRLF & _
"Message-ID: <15464986.1075855378456.JavaMail.evans@thyme>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")