package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`X-FileName:.*[\r\n]+(.+)`)
var str = `X-FileName: pallen (Non-Privileged).pst
Here is our forecast
Message-ID: <15464986.1075855378456.JavaMail.evans@thyme>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}