using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"X-FileName:.*[\r\n]+(.+)";
string input = @"X-FileName: pallen (Non-Privileged).pst
Here is our forecast
Message-ID: <15464986.1075855378456.JavaMail.evans@thyme>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}