re = /X-FileName:.*[\r\n]+(.+)/
str = 'X-FileName: pallen (Non-Privileged).pst
Here is our forecast
Message-ID: <15464986.1075855378456.JavaMail.evans@thyme>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end