import re
regex = re.compile(r"^\s*\{\/\*DELETE}(\s*(?:\r?\n(?!\s*\{(?:\/\*DELETE|DELETE\*\/)}).*)*)\r?\n\s*\{DELETE\*\/}\s*$", flags=re.MULTILINE)
test_str = ("Keep1\n"
"{/*DELETE}\n"
"Delete1a\n"
" {/*DELETE}\n"
" Delete2\n"
" {DELETE*/}\n"
"Delete1b\n"
"{DELETE*/}\n"
"Keep2\n"
"{/*DELETE}\n"
"Delete3\n"
"{DELETE*/}\n"
"Keep3")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)