using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\[[^""]*""(.*?)""[^]""]*\]";
string input = @"
[
""this is a text and its supposed to contain every possible char.""
],
[
""like *.;#]§< and many "" more.""
],
[
""plus there are even
newlines
in it.""
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}