re = /(?s)\[[^"]*"(.*?)"[^]"]*\]/m
str = '
[
"this is a text and its supposed to contain every possible char."
],
[
"like *.;#]§< and many "" more."
],
[
"plus there are even
newlines
in it."
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end