package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\[[^"]*"(.*?)"[^]"]*\]`)
var str = `
[
"this is a text and its supposed to contain every possible char."
],
[
"like *.;#]§< and many "" more."
],
[
"plus there are even
newlines
in it."
]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}