import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\[[^\"]*\"(.*?)\"[^]\"]*\\]";
final String string = "\n"
+ " [\n"
+ " \"this is a text and its supposed to contain every possible char.\"\n"
+ " ],\n"
+ " [\n"
+ " \"like *.;#]§< and many \"\" more.\"\n"
+ " ],\n"
+ " [\n"
+ " \"plus there are even\n"
+ "newlines\n\n"
+ "in it.\"\n"
+ " ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}