$re = '/(https?[^\s?]+\?\S+)/';
$str = 'https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
';
$subst = "$1&o=desc&s=updated";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;