const regex = new RegExp('[A-Z].*?\\w[.?!](?<!\\ba\\.m\\.)(?!\\S)', 'gm')
const str = `At 9:00 a.m. the store opens.
At 9:00 p.m. the store opens.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}