re = /[A-Z].*?\w[.?!](?<!\ba\.m\.)(?!\S)/m
str = 'At 9:00 a.m. the store opens.
At 9:00 p.m. the store opens.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end