import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:^|[^a-z0-9])#)(?!.*#(?:$|[^a-z0-9])).+$";
final String string = "ex_date( ds23d#d4ff5 ) \n"
+ "ex_date( asa#ss32as, #, s3ds#sdsd) \n"
+ "ex_date12(asa#ss32as,#,s3ds#sdsd) \n"
+ "( asa#ss32as, a#b, s3ds#sdsd) \n"
+ "date( asa#ss32as, #, s3ds#sdsd, a#b) \n"
+ "ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5) \n"
+ "ewe#ewe \n"
+ "we#ere, er2e#er3e, # \n"
+ "p_price(we#ee) \n"
+ "p_date( we#rer , ) \n"
+ "p_car ( df#e ,) \n"
+ "re#ee , erer#r,\n"
+ "#wewqwq\n"
+ "ddf$%^#gfg^h";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}