# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*(?:^|[^a-z0-9])#)(?!.*#(?:$|[^a-z0-9])).+$"
test_str = ("ex_date( ds23d#d4ff5 ) \n"
"ex_date( asa#ss32as, #, s3ds#sdsd) \n"
"ex_date12(asa#ss32as,#,s3ds#sdsd) \n"
"( asa#ss32as, a#b, s3ds#sdsd) \n"
"date( asa#ss32as, #, s3ds#sdsd, a#b) \n"
"ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5) \n"
"ewe#ewe \n"
"we#ere, er2e#er3e, # \n"
"p_price(we#ee) \n"
"p_date( we#rer , ) \n"
"p_car ( df#e ,) \n"
"re#ee , erer#r,\n"
"#wewqwq\n"
"ddf$%^#gfg^h")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.