use strict;
my $str = 'ex_date( ds23d#d4ff5 )
ex_date( asa#ss32as, #, s3ds#sdsd)
ex_date12(asa#ss32as,#,s3ds#sdsd)
( asa#ss32as, a#b, s3ds#sdsd)
date( asa#ss32as, #, s3ds#sdsd, a#b)
ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5)
ewe#ewe
we#ere, er2e#er3e, #
p_price(we#ee)
p_date( we#rer , )
p_car ( df#e ,)
re#ee , erer#r,
#wewqwq
ddf$%^#gfg^h';
my $regex = qr/^(?!.*(?:^|[^a-z0-9])#)(?!.*#(?:$|[^a-z0-9])).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}