$re = '/^(?!.*(?:^|[^a-z0-9])#)(?!.*#(?:$|[^a-z0-9])).+$/m';
$str = 'ex_date( ds23d#d4ff5 )
ex_date( asa#ss32as, #, s3ds#sdsd)
ex_date12(asa#ss32as,#,s3ds#sdsd)
( asa#ss32as, a#b, s3ds#sdsd)
date( asa#ss32as, #, s3ds#sdsd, a#b)
ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5)
ewe#ewe
we#ere, er2e#er3e, #
p_price(we#ee)
p_date( we#rer , )
p_car ( df#e ,)
re#ee , erer#r,
#wewqwq
ddf$%^#gfg^h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);