using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:NOTTHISWORD-|(\w*SAT-))\b";
string input = @"new_appointment_requested; general; SAT-newlead; NOTTHISWORD-SAT-newlead";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}