$re = '/\b(?:NOTTHISWORD-|(\w*SAT-))\b/m';
$str = 'new_appointment_requested; general; SAT-newlead; NOTTHISWORD-SAT-newlead';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);