package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:NOTTHISWORD-|(\w*SAT-))\b`)
var str = `new_appointment_requested; general; SAT-newlead; NOTTHISWORD-SAT-newlead`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}