re = /\b(?:NOTTHISWORD-|(\w*SAT-))\b/m
str = 'new_appointment_requested; general; SAT-newlead; NOTTHISWORD-SAT-newlead'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end