#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b([a-z])?([a-z])?([a-z])?\2\1\b"
Local $sString = "words that are the same backwards as forwards" & @CRLF & _
"e.g:" & @CRLF & _
"kayak, dewed, refer, hanah, but not hannah or henah or ana, nor wow or racecar."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")