$re = '/\b([a-z])?([a-z])?([a-z])?\2\1\b/i';
$str = 'words that are the same backwards as forwards
e.g:
kayak, dewed, refer, hanah, but not hannah or henah or ana, nor wow or racecar.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);