import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([a-z])?([a-z])?([a-z])?\\2\\1\\b";
final String string = "words that are the same backwards as forwards\n"
+ "e.g:\n"
+ "kayak, dewed, refer, hanah, but not hannah or henah or ana, nor wow or racecar.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}