#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[0-9]).{1,10}$"
Local $sString = "" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"1234567890" & @CRLF & _
"12345678901" & @CRLF & _
"a" & @CRLF & _
"abcd" & @CRLF & _
"abcdefgh" & @CRLF & _
"ABC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")