$re = '/^(?=[0-9]).{1,10}$/m';
$str = '
1
2
1234567890
12345678901
a
abcd
abcdefgh
ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);