re = /^(?=[0-9]).{1,10}$/m
str = '
1
2
1234567890
12345678901
a
abcd
abcdefgh
ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end